HashiCorp Nomad Users Beware of Arbitrary File Write Vulnerability

CVECVE-2024-1329
CVSScvssV3_1: 7.7
SourceCVE-2024-1329

HashiCorp Nomad is an open source tool for deploying and managing containerized applications across datacenter infrastructure. According to security researchers, versions 1.5.13 up to 1.6.6, and 1.7.3 of Nomad are vulnerable to arbitrary file write attacks on the host system through symlink attacks.

Attackers could potentially exploit this vulnerability by submitting a job specification to the Nomad server that uses symlinks to write files outside of the expected job directory. Since the Nomad client runs as the host user, this could allow an attacker to overwrite important files and gain unauthorized access to the system.

The best way to protect yourself is to immediately update your Nomad installation to the latest versions 1.7.4, 1.6.7 or 1.5.14 which have fixes for this issue. You should also carefully review any job specifications submitted to your Nomad servers and filter out unexpected symlinks. Applying the principle of least privilege is also recommended – running the Nomad client with a non-root user instead of the host user can help minimize damage from any future exploits.

Staying on top of software updates is critical for security. So check your Nomad versions and update right away if vulnerable. Reviewing configurations and restricting privileges can also help lock down your systems.

References