Upgrade Squid Now to Patch Serious Denial of Service Vulnerability

CVSScvssV3_1: 8.6

Squid, the popular web caching proxy software, is affected by a serious vulnerability that can allow attackers to cause a denial of service (DoS) condition.

Versions of Squid from 3.5 up to and including 5.9 are vulnerable if they have “collapsed_forwarding” enabled in their configuration. This feature is used to optimize performance but it contains a use-after-free bug that can be exploited.

An attacker can send specially crafted requests that trigger the bug, crashing the Squid process and disrupting the caching services it provides. This would negatively impact any users or applications relying on Squid.

The good news is that Squid developers have addressed the issue in version 6.0.1. All Squid administrators are highly recommended to upgrade immediately. If upgrading is not possible for any reason, the collapsed_forwarding option should be disabled as a workaround.

Taking steps now to patch or disable the vulnerable feature protects networks from potential downtime caused by exploitation of this flaw. Staying on top of software updates is important for any internet-facing services.