WordPress ContentStudio Plugin Authorization Bypass Vulnerability Allows Unauthenticated Users to Create Posts

CVECVE-2023-0556
CVSScvssV3_1: 9.8
SourceCVE-2023-0556

The ContentStudio plugin for WordPress is vulnerable to an authorization bypass issue. This vulnerability has been assigned the identifier CVE-2023-0556 and has a CVSS score of 9.8, making it a critical issue.

Due to a missing capability check, unauthenticated attackers can obtain the blog metadata from the cstu_get_metadata function in versions of ContentStudio up to and including 1.2.5. This metadata includes the plugin’s contentstudio_token. With knowledge of this token, attackers can then interact with other functions in the plugin, such as creating posts.

This allows outsiders without any login credentials to bypass authorization and publish content directly to the affected WordPress site. As ContentStudio is a plugin for managing blog posts, this poses a risk of unauthorized or malicious content being placed on the site.

ContentStudio users are advised to update to version 1.2.6 or later immediately to apply the fix. Administrators should also consider rotating or revoking any API or authentication tokens if they were exposed by this vulnerability. Staying on top of updates for plugins and themes is important for keeping WordPress sites secure.

References